{"action":"Upgrade pyjwt to 1.5.1 or later.","affected":[{"fixed":"1.5.1","introduced":"0"}],"component":"pyjwt","cve_ids":["CVE-2017-11424"],"ecosystem":"PyPI","epss":0.01804,"exploited":false,"fixed_versions":["1.5.1"],"ghsa_id":"GHSA-r9jw-mwhq-wp62","id":"tcs_01M5KFXMYKSHWHQA9VRFWKP8WJ","modified_at":"2024-12-05T05:30:36.784778Z","published_at":"2022-05-13T01:42:19Z","references":["https://osv.dev/vulnerability/GHSA-r9jw-mwhq-wp62","https://nvd.nist.gov/vuln/detail/CVE-2017-11424","https://github.com/jpadilla/pyjwt/pull/277","https://github.com/jpadilla/pyjwt","https://github.com/pypa/advisory-database/tree/main/vulns/pyjwt/PYSEC-2017-24.yaml","http://www.debian.org/security/2017/dsa-3979"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-r9jw-mwhq-wp62","url":"https://osv.dev/vulnerability/GHSA-r9jw-mwhq-wp62"}],"summary":"PyJWT vulnerable to key confusion attacks"}