{"action":"Upgrade apache-airflow-providers-apache-hive to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"apache-airflow-providers-apache-hive","cve_ids":["CVE-2022-46421"],"ecosystem":"PyPI","epss":0.03286,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-rc58-qr9j-cpgw","id":"tcs_01M5KFXNSCPVRQ437GPM6E7R8A","modified_at":"2026-06-29T12:26:39.831708520Z","published_at":"2022-12-20T12:30:22Z","references":["https://osv.dev/vulnerability/GHSA-rc58-qr9j-cpgw","https://nvd.nist.gov/vuln/detail/CVE-2022-46421","https://github.com/apache/airflow/pull/28101","https://github.com/apache/airflow","https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-rc58-qr9j-cpgw","url":"https://osv.dev/vulnerability/GHSA-rc58-qr9j-cpgw"}],"summary":"Apache Airflow Hive Provider vulnerable to Command Injection"}