{"action":"Upgrade hawk to 3.1.3 or later.","affected":[{"fixed":"4.1.1","introduced":"4.0.0"},{"fixed":"3.1.3","introduced":"0"}],"component":"hawk","cve_ids":["CVE-2016-2515"],"ecosystem":"npm","epss":0.0337,"exploited":false,"fixed_versions":["4.1.1","3.1.3"],"ghsa_id":"GHSA-jcpv-g9rr-qxrc","id":"tcs_01M5KFXPRM27BRJDWWG4VN6S21","modified_at":"2023-11-08T03:58:24.587802Z","published_at":"2018-07-31T22:52:00Z","references":["https://osv.dev/vulnerability/GHSA-jcpv-g9rr-qxrc","https://nvd.nist.gov/vuln/detail/CVE-2016-2515","https://github.com/hueniverse/hawk/issues/168","https://github.com/hueniverse/hawk/commit/0833f99ba64558525995a7e21d4093da1f3e15fa","https://bugzilla.redhat.com/show_bug.cgi?id=1309721","https://github.com/advisories/GHSA-jcpv-g9rr-qxrc","https://github.com/hueniverse/hawk","https://www.npmjs.com/advisories/77","http://www.openwall.com/lists/oss-security/2016/02/20/1","http://www.openwall.com/lists/oss-security/2016/02/20/2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-jcpv-g9rr-qxrc","url":"https://osv.dev/vulnerability/GHSA-jcpv-g9rr-qxrc"}],"summary":"Regular Expression Denial of Service in hawk"}