{"action":"Upgrade nvflare to 2.1.2 or later.","affected":[{"fixed":"2.1.2","introduced":"0"}],"component":"nvflare","cve_ids":["CVE-2022-31604"],"ecosystem":"PyPI","epss":0.02079,"exploited":false,"fixed_versions":["2.1.2"],"ghsa_id":"GHSA-rcxc-3w2m-mp8h","id":"tcs_01M5KFXSXBZR9WBZD3YV41HNZR","modified_at":"2026-07-08T06:27:52.366539509Z","published_at":"2022-06-22T21:22:42Z","references":["https://osv.dev/vulnerability/GHSA-rcxc-3w2m-mp8h","https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-rcxc-3w2m-mp8h","https://nvd.nist.gov/vuln/detail/CVE-2022-31604","https://github.com/NVIDIA/NVFlare/commit/fd018eea9dff925a765079a94c2f017920fcda67","https://github.com/NVIDIA/NVFlare","https://github.com/pypa/advisory-database/tree/main/vulns/nvflare/PYSEC-2022-231.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-rcxc-3w2m-mp8h","url":"https://osv.dev/vulnerability/GHSA-rcxc-3w2m-mp8h"}],"summary":"Unsafe deserialisation in the PKI implementation scheme of NVFlare"}