{"action":"Upgrade p4 to 0.0.7 or later.","affected":[{"fixed":"0.0.7","introduced":"0"}],"component":"p4","cve_ids":["CVE-2022-25171"],"ecosystem":"npm","epss":0.0247,"exploited":false,"fixed_versions":["0.0.7"],"ghsa_id":"GHSA-jfm8-hwhg-r6gg","id":"tcs_01M5KFXWGRAWFR295P1CW0T0MT","modified_at":"2025-04-16T16:08:22Z","published_at":"2022-12-20T06:30:36Z","references":["https://osv.dev/vulnerability/GHSA-jfm8-hwhg-r6gg","https://nvd.nist.gov/vuln/detail/CVE-2022-25171","https://github.com/natelong/p4/commit/ae42e251beabf67c00539ec0e1d7aa149ca445fb","https://github.com/natelong/p4","https://github.com/natelong/p4/blob/master/p4.js#23L12","https://security.snyk.io/vuln/SNYK-JS-P4-3167330"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"GHSA-jfm8-hwhg-r6gg","url":"https://osv.dev/vulnerability/GHSA-jfm8-hwhg-r6gg"}],"summary":"p4 vulnerable to Command Injection due to improper input sanitization"}