{"action":"Upgrade tensorflow-gpu to 2.4.4 or later.","affected":[{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-41224"],"ecosystem":"PyPI","epss":0.00208,"exploited":false,"fixed_versions":["2.6.1","2.5.2","2.4.4"],"ghsa_id":"GHSA-rg3m-hqc5-344v","id":"tcs_01M5KFXY8F4HPEQGW4TF1G1FS6","modified_at":"2026-07-08T06:28:20.691095307Z","published_at":"2021-11-10T18:45:55Z","references":["https://osv.dev/vulnerability/GHSA-rg3m-hqc5-344v","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rg3m-hqc5-344v","https://nvd.nist.gov/vuln/detail/CVE-2021-41224","https://github.com/tensorflow/tensorflow/commit/67bfd9feeecfb3c61d80f0e46d89c170fbee682b","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-633.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-831.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-416.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-rg3m-hqc5-344v#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-rg3m-hqc5-344v"}],"summary":"`SparseFillEmptyRows` heap OOB"}