{"action":"Upgrade github.com/usememos/memos to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0"}],"component":"github.com/usememos/memos","cve_ids":["CVE-2022-4690"],"ecosystem":"Go","epss":0.00642,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-c8jh-vcjh-fx2w","id":"tcs_01M5KFY2YWXDM6VND4NKG5KDF6","modified_at":"2026-03-03T04:52:49.880700Z","published_at":"2024-08-21T16:03:59Z","references":["https://osv.dev/vulnerability/GO-2022-1189","https://github.com/advisories/GHSA-c8jh-vcjh-fx2w","https://nvd.nist.gov/vuln/detail/CVE-2022-4690","https://github.com/usememos/memos/commit/65cc19c12efa392f792f6bb154b4838547e0af5e","https://github.com/usememos/memos/commit/c07b4a57caa89905e54b800f4d8fb720bbf5bf82","https://github.com/usememos/memos/pull/833","https://github.com/usememos/memos","https://huntr.dev/bounties/7e1be91d-3b13-4300-8af2-9bd9665ec335"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2022-1189","url":"https://osv.dev/vulnerability/GO-2022-1189"}],"summary":"usememos/memos vulnerable to stored cross-site scripting (XSS) in github.com/usememos/memos"}