{"action":"Upgrade @node-oauth/oauth2-server to 5.3.0 or later.","affected":[{"fixed":"5.3.0","introduced":"0"}],"component":"@node-oauth/oauth2-server","cve_ids":["CVE-2026-41213"],"ecosystem":"npm","epss":0.00259,"exploited":false,"fixed_versions":["5.3.0"],"ghsa_id":"GHSA-jhm7-29pj-4xvf","id":"tcs_01M5KFY4TEPYDTR0YSV0MZGA50","modified_at":"2026-05-05T16:11:45.707781Z","published_at":"2026-04-16T21:09:50Z","references":["https://osv.dev/vulnerability/GHSA-jhm7-29pj-4xvf","https://github.com/node-oauth/node-oauth2-server/security/advisories/GHSA-jhm7-29pj-4xvf","https://nvd.nist.gov/vuln/detail/CVE-2026-41213","https://github.com/node-oauth/node-oauth2-server"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-jhm7-29pj-4xvf","url":"https://osv.dev/vulnerability/GHSA-jhm7-29pj-4xvf"}],"summary":"@node-oauth/oauth2-server: PKCE code_verifier ABNF not enforced in token exchange allows brute-force redemption of intercepted authorization codes"}