{"action":"Upgrade shescape to 1.5.8 or later.","affected":[{"fixed":"1.5.8","introduced":"0"}],"component":"shescape","cve_ids":["CVE-2022-31179"],"ecosystem":"npm","epss":0.01424,"exploited":false,"fixed_versions":["1.5.8"],"ghsa_id":"GHSA-jjc5-fp7p-6f8w","id":"tcs_01M5KFY8M9HAX5HK4KEN773X2B","modified_at":"2023-11-08T04:09:28.955315Z","published_at":"2022-07-15T21:39:14Z","references":["https://osv.dev/vulnerability/GHSA-jjc5-fp7p-6f8w","https://github.com/ericcornelissen/shescape/security/advisories/GHSA-jjc5-fp7p-6f8w","https://nvd.nist.gov/vuln/detail/CVE-2022-31179","https://github.com/ericcornelissen/shescape/pull/332","https://github.com/ericcornelissen/shescape/commit/aceea7358f7222984e21260381ebc5ec4543b76f","https://github.com/ericcornelissen/shescape","https://github.com/ericcornelissen/shescape/releases/tag/v1.5.8"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-jjc5-fp7p-6f8w","url":"https://osv.dev/vulnerability/GHSA-jjc5-fp7p-6f8w"}],"summary":"Shescape prior to 1.5.8 vulnerable to insufficient escaping of line feeds for CMD"}