{"action":"Upgrade celery to 2.2.8 or later.","affected":[{"fixed":"2.2.8","introduced":"2.1.0"},{"fixed":"2.3.4","introduced":"2.3.0"},{"fixed":"2.4.4","introduced":"2.4.0"}],"component":"celery","cve_ids":["CVE-2011-4356"],"ecosystem":"PyPI","epss":0.0033,"exploited":false,"fixed_versions":["2.2.8","2.3.4","2.4.4"],"ghsa_id":"GHSA-rpc6-h455-3rx5","id":"tcs_01M5KFYC0PW6MNBE778RHXR2BT","modified_at":"2024-12-08T05:25:41.675688Z","published_at":"2022-05-17T05:36:00Z","references":["https://osv.dev/vulnerability/GHSA-rpc6-h455-3rx5","https://nvd.nist.gov/vuln/detail/CVE-2011-4356","https://github.com/celery/celery/pull/544","https://github.com/celery/celery/commit/53514b158b743678d8993638be5920cd09ccc35c","https://github.com/celery/celery/commit/73388921731a0e6feb28ab0d389c4f7dc4d524f6","https://github.com/celery/celery/commit/e0767e40994754fe8482bf4ff622c5c6d0b9f671","https://github.com/celery/celery","https://github.com/celery/celery/blob/master/docs/sec/CELERYSA-0001.txt","https://github.com/pypa/advisory-database/tree/main/vulns/celery/PYSEC-2011-17.yaml","https://web.archive.org/web/20140722114447/http://secunia.com/advisories/46973","https://web.archive.org/web/20200305001706/http://www.securityfocus.com/bid/50825"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-rpc6-h455-3rx5","url":"https://osv.dev/vulnerability/GHSA-rpc6-h455-3rx5"}],"summary":"Celery local privilege escalation vulnerability"}