{"action":"Upgrade eth-abi to 4.2.0 or later.","affected":[{"fixed":"4.2.0","introduced":"0"}],"component":"eth-abi","cve_ids":[],"ecosystem":"PyPI","exploited":false,"fixed_versions":["4.2.0"],"ghsa_id":"GHSA-rqr8-pxh7-cq3g","id":"tcs_01M5KFYFBGVN9T62J4RAP8AYJ3","modified_at":"2024-11-28T05:27:22.642405Z","published_at":"2023-11-24T16:54:11Z","references":["https://osv.dev/vulnerability/GHSA-rqr8-pxh7-cq3g","https://github.com/ethereum/eth-abi/security/advisories/GHSA-rqr8-pxh7-cq3g","https://github.com/ethereum/eth-abi"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-rqr8-pxh7-cq3g","url":"https://osv.dev/vulnerability/GHSA-rqr8-pxh7-cq3g"}],"summary":"Ethereum ABI decoder DoS when parsing ZST"}