{"action":"Upgrade oauth2 to 1.9rc1 or later.","affected":[{"fixed":"1.9rc1","introduced":"0"}],"component":"oauth2","cve_ids":["CVE-2013-4347"],"ecosystem":"PyPI","epss":0.0245,"exploited":false,"fixed_versions":["1.9rc1"],"ghsa_id":"GHSA-rv8h-p43r-4x5r","id":"tcs_01M5KFYNZVEGT523W5891BEK7S","modified_at":"2024-10-07T21:26:00.260793Z","published_at":"2022-05-17T03:46:28Z","references":["https://osv.dev/vulnerability/GHSA-rv8h-p43r-4x5r","https://nvd.nist.gov/vuln/detail/CVE-2013-4347","https://github.com/simplegeo/python-oauth2/issues/9","https://github.com/simplegeo/python-oauth2/pull/146","https://github.com/joestump/python-oauth2/commit/82dd2cdd4954cd7b8983d5d64c0dfd9072bf4650","https://access.redhat.com/errata/RHSA-2015:1591","https://access.redhat.com/errata/RHSA-2015:1592","https://access.redhat.com/security/cve/CVE-2013-4347","https://bugzilla.redhat.com/show_bug.cgi?id=1007758","https://github.com/joestump/python-oauth2","https://github.com/pypa/advisory-database/tree/main/vulns/oauth2/PYSEC-2014-86.yaml","http://www.openwall.com/lists/oss-security/2013/09/12/7","http://www.securityfocus.com/bid/62388"],"severity":{"label":"low","score":3.7},"sources":[{"source":"osv","source_id":"GHSA-rv8h-p43r-4x5r","url":"https://osv.dev/vulnerability/GHSA-rv8h-p43r-4x5r"}],"summary":"SimpleGeo python-oauth2 vulnerable to the use of Insufficiently Random Values to generate nonces"}