{"action":"Upgrade vllm to 0.10.1.1 or later.","affected":[{"fixed":"0.10.1.1","introduced":"0.1.0"}],"component":"vllm","cve_ids":["CVE-2025-48956"],"ecosystem":"PyPI","epss":0.00565,"exploited":false,"fixed_versions":["0.10.1.1"],"ghsa_id":"GHSA-rxc4-3w6r-4v47","id":"tcs_01M5KFYVZAB700XQQWAZYTQCVD","modified_at":"2026-09-10T03:50:27.365803772Z","published_at":"2025-08-21T14:24:16Z","references":["https://osv.dev/vulnerability/GHSA-rxc4-3w6r-4v47","https://github.com/vllm-project/vllm/security/advisories/GHSA-rxc4-3w6r-4v47","https://nvd.nist.gov/vuln/detail/CVE-2025-48956","https://github.com/vllm-project/vllm/pull/23267","https://github.com/vllm-project/vllm/commit/d8b736f913a59117803d6701521d2e4861701944","https://github.com/advisories/GHSA-rxc4-3w6r-4v47","https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2021.yaml","https://github.com/vllm-project/vllm","https://pypi.org/project/vllm"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-rxc4-3w6r-4v47","url":"https://osv.dev/vulnerability/GHSA-rxc4-3w6r-4v47"}],"summary":"vllm API endpoints vulnerable to Denial of Service Attacks"}