{"action":"Upgrade dom-iterator to 1.0.1 or later.","affected":[{"fixed":"1.0.1","introduced":"0"}],"component":"dom-iterator","cve_ids":["CVE-2024-21541"],"ecosystem":"npm","epss":0.01082,"exploited":false,"fixed_versions":["1.0.1"],"ghsa_id":"GHSA-jrvm-mcxc-mf6m","id":"tcs_01M5KFYWFPYJMH96KM2B91G1B0","modified_at":"2025-01-14T21:18:03Z","published_at":"2024-11-13T06:30:29Z","references":["https://osv.dev/vulnerability/GHSA-jrvm-mcxc-mf6m","https://nvd.nist.gov/vuln/detail/CVE-2024-21541","https://github.com/matthewmueller/dom-iterator/commit/9e0e0fad5a251de5b42feb326c4204eb04080805","https://github.com/matthewmueller/dom-iterator","https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-8383166","https://security.snyk.io/vuln/SNYK-JS-DOMITERATOR-6157199"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"GHSA-jrvm-mcxc-mf6m","url":"https://osv.dev/vulnerability/GHSA-jrvm-mcxc-mf6m"}],"summary":"dom-iterator code execution vulnerability"}