{"action":"Upgrade confidant to 6.6.2 or later.","affected":[{"fixed":"6.6.2","introduced":"0"}],"component":"confidant","cve_ids":["CVE-2024-45793"],"ecosystem":"PyPI","epss":0.00359,"exploited":false,"fixed_versions":["6.6.2"],"ghsa_id":"GHSA-rxq8-q85f-m866","id":"tcs_01M5KFYX28Y6C8FYM5K3WJBAR2","modified_at":"2026-07-07T17:56:32.718203847Z","published_at":"2024-09-20T15:45:23Z","references":["https://osv.dev/vulnerability/GHSA-rxq8-q85f-m866","https://github.com/lyft/confidant/security/advisories/GHSA-rxq8-q85f-m866","https://nvd.nist.gov/vuln/detail/CVE-2024-45793","https://github.com/lyft/confidant/commit/8876b07abde0c8d2a4974f79b60562b6d0193db9","https://hackerone.com/reports/2332004","https://hackerone.com/reports/2456673","https://hackerone.com/reports/2476542","https://github.com/lyft/confidant"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-rxq8-q85f-m866","url":"https://osv.dev/vulnerability/GHSA-rxq8-q85f-m866"}],"summary":"Prevent XSS from Confidant API call"}