{"action":"Upgrade apache-airflow to 3.0.5 or later.","affected":[{"fixed":"3.0.5","introduced":"3.0.0"}],"component":"apache-airflow","cve_ids":["CVE-2025-54941"],"ecosystem":"PyPI","epss":0.00492,"exploited":false,"fixed_versions":["3.0.5"],"ghsa_id":"GHSA-v3c9-j6h9-66v4","id":"tcs_01M5KFZ2NYVH0199XDYRQWTG96","modified_at":"2026-07-07T17:56:51.615482094Z","published_at":"2025-10-30T12:31:11Z","references":["https://osv.dev/vulnerability/GHSA-v3c9-j6h9-66v4","https://nvd.nist.gov/vuln/detail/CVE-2025-54941","https://github.com/apache/airflow","https://lists.apache.org/thread/c6q6nofc6xl5bms039ks9b34v0v36df1","http://www.openwall.com/lists/oss-security/2025/10/29/6"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-v3c9-j6h9-66v4","url":"https://osv.dev/vulnerability/GHSA-v3c9-j6h9-66v4"},{"source":"nvd","source_id":"CVE-2025-54941","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-54941"}],"summary":"Apache Airflow has a command injection vulnerability in \"example_dag_decorator\""}