{"action":"Upgrade pipreqs to 0.4.12 or later.","affected":[{"fixed":"0.4.12","introduced":"0.3.0"}],"component":"pipreqs","cve_ids":["CVE-2023-31543"],"ecosystem":"PyPI","epss":0.01187,"exploited":false,"fixed_versions":["0.4.12"],"ghsa_id":"GHSA-v4f4-23wc-99mh","id":"tcs_01M5KFZ57R309B1BS6DARPDXXK","modified_at":"2024-10-14T18:48:38.278705Z","published_at":"2023-06-30T21:30:26Z","references":["https://osv.dev/vulnerability/GHSA-v4f4-23wc-99mh","https://nvd.nist.gov/vuln/detail/CVE-2023-31543","https://github.com/bndr/pipreqs/pull/364","https://github.com/bndr/pipreqs/commit/3f5964fcb90ec6eb6df46d78e651a1b73538d0ba","https://gist.github.com/adeadfed/ccc834440af354a5638f889bee34bafe","https://github.com/bndr/pipreqs","https://github.com/bndr/pipreqs/blob/master/pipreqs/pipreqs.py#L447-L449","https://github.com/pypa/advisory-database/tree/main/vulns/pipreqs/PYSEC-2023-99.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-v4f4-23wc-99mh","url":"https://osv.dev/vulnerability/GHSA-v4f4-23wc-99mh"}],"summary":"pipreqs vulnerable to Dependency Confusion"}