{"action":"Upgrade pydrive2 to 1.16.2 or later.","affected":[{"fixed":"1.16.2","introduced":"0"}],"component":"pydrive2","cve_ids":["CVE-2023-49297"],"ecosystem":"PyPI","epss":0.0051,"exploited":false,"fixed_versions":["1.16.2"],"ghsa_id":"GHSA-v5f6-hjmf-9mc5","id":"tcs_01M5KFZ8HTAF10GDYX5EZWAGN5","modified_at":"2026-09-10T03:50:09.173407956Z","published_at":"2023-12-05T23:43:07Z","references":["https://osv.dev/vulnerability/GHSA-v5f6-hjmf-9mc5","https://github.com/iterative/PyDrive2/security/advisories/GHSA-v5f6-hjmf-9mc5","https://nvd.nist.gov/vuln/detail/CVE-2023-49297","https://github.com/iterative/PyDrive2/commit/c57355dc2033ad90b7050d681b2c3ba548ff0004","https://github.com/iterative/PyDrive2","https://github.com/pypa/advisory-database/tree/main/vulns/pydrive2/PYSEC-2023-291.yaml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CYR5SJKOFSSXFV3E3D2SLXBUBA5WMJJG","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/K34YWTDKBAYWZPOAKBYDM72WIFL5CAYW"],"severity":{"label":"low","score":3.3},"sources":[{"source":"osv","source_id":"GHSA-v5f6-hjmf-9mc5","url":"https://osv.dev/vulnerability/GHSA-v5f6-hjmf-9mc5"}],"summary":"PyDrive2's unsafe YAML deserialization in LoadSettingsFile allows arbitrary code execution"}