{"action":"Upgrade vm2 to 3.11.7 or later.","affected":[{"fixed":"3.11.7","introduced":"0"}],"component":"vm2","cve_ids":["CVE-2026-92950"],"ecosystem":"npm","epss":0.00197,"exploited":false,"fixed_versions":["3.11.7"],"ghsa_id":"GHSA-jxxv-8r27-vm4p","id":"tcs_01M5KFZ9A9XGBCHMYHQRGSQ52M","modified_at":"2026-10-01T16:00:04.783958622Z","published_at":"2026-10-01T15:40:45Z","references":["https://osv.dev/vulnerability/GHSA-jxxv-8r27-vm4p","https://github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p","https://nvd.nist.gov/vuln/detail/CVE-2026-92950","https://github.com/patriksimek/vm2/commit/903017c8a1eae9aba947ec854468b48155e79f86","https://github.com/patriksimek/vm2","https://github.com/patriksimek/vm2/releases/tag/v3.11.7","https://www.vulncheck.com/advisories/vm2-before-3.11.7-sandbox-escape-via-cli-require"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"GHSA-jxxv-8r27-vm4p","url":"https://osv.dev/vulnerability/GHSA-jxxv-8r27-vm4p"}],"summary":"vm2 CLI provides no sandbox isolation - host-realm require() is reachable from sandboxed scripts"}