{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29577"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-v6r6-84gr-92rm","id":"tcs_01M5KFZDS1ERYWW35135HKT8A2","modified_at":"2026-07-08T06:28:05.366079699Z","published_at":"2021-05-21T14:26:18Z","references":["https://osv.dev/vulnerability/GHSA-v6r6-84gr-92rm","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-v6r6-84gr-92rm","https://nvd.nist.gov/vuln/detail/CVE-2021-29577","https://github.com/tensorflow/tensorflow/commit/6fc9141f42f6a72180ecd24021c3e6b36165fe0d","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-505.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-703.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-214.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-v6r6-84gr-92rm#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-v6r6-84gr-92rm"}],"summary":"Heap buffer overflow in `AvgPool3DGrad`"}