{"action":"Upgrade binary-parser to 2.3.0 or later.","affected":[{"fixed":"2.3.0","introduced":"0"}],"component":"binary-parser","cve_ids":["CVE-2026-1245"],"ecosystem":"npm","epss":0.00563,"exploited":false,"fixed_versions":["2.3.0"],"ghsa_id":"GHSA-m39p-34qh-rh3w","id":"tcs_01M5KFZF3KW2BBB39CRRBQA86E","modified_at":"2026-02-03T03:11:22.190245Z","published_at":"2026-01-20T21:31:34Z","references":["https://osv.dev/vulnerability/GHSA-m39p-34qh-rh3w","https://nvd.nist.gov/vuln/detail/CVE-2026-1245","https://github.com/keichi/binary-parser/pull/283","https://github.com/keichi/binary-parser","https://kb.cert.org/vuls/id/102648","https://www.cve.org/CVERecord?id=CVE-2026-1245","https://www.kb.cert.org/vuls/id/102648","https://www.npmjs.com/package/binary-parser"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-m39p-34qh-rh3w","url":"https://osv.dev/vulnerability/GHSA-m39p-34qh-rh3w"}],"summary":"binary-parser library has a code injection vulnerability"}