{"action":"Upgrade langchain-experimental to 0.0.52 or later.","affected":[{"fixed":"0.0.52","introduced":"0"}],"component":"langchain-experimental","cve_ids":["CVE-2024-27444"],"ecosystem":"PyPI","epss":0.00773,"exploited":false,"fixed_versions":["0.0.52"],"ghsa_id":"GHSA-v8vj-cv27-hjv8","id":"tcs_01M5KFZP1FA60R7Y0MV3D5K7BR","modified_at":"2026-06-29T12:26:27.368289803Z","published_at":"2024-02-26T18:30:31Z","references":["https://osv.dev/vulnerability/GHSA-v8vj-cv27-hjv8","https://nvd.nist.gov/vuln/detail/CVE-2024-27444","https://github.com/langchain-ai/langchain/commit/de9a6cdf163ed00adaf2e559203ed0a9ca2f1de7","https://github.com/langchain-ai/langchain"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-v8vj-cv27-hjv8","url":"https://osv.dev/vulnerability/GHSA-v8vj-cv27-hjv8"}],"summary":"LangChain Experimental vulnerable to arbitrary code execution"}