{"action":"Upgrade python-gnupg to 0.3.7 or later.","affected":[{"fixed":"0.3.7","introduced":"0.3.5"}],"component":"python-gnupg","cve_ids":["CVE-2014-1929"],"ecosystem":"PyPI","epss":0.00386,"exploited":false,"fixed_versions":["0.3.7"],"ghsa_id":"GHSA-vcr5-xr9h-mvc5","id":"tcs_01M5KFZYNX5BVAQ7FZ1HCGXD80","modified_at":"2024-10-25T21:23:41.396575Z","published_at":"2018-11-06T23:12:48Z","references":["https://osv.dev/vulnerability/GHSA-vcr5-xr9h-mvc5","https://nvd.nist.gov/vuln/detail/CVE-2014-1929","https://alioth-lists.debian.net/pipermail/debian-security-tracker-commits/2014-June/028512.html","https://code.google.com/archive/p/python-gnupg/issues/98","https://github.com/advisories/GHSA-vcr5-xr9h-mvc5","https://github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-92.yaml","https://github.com/vsajip/python-gnupg","https://web.archive.org/web/20200228170437/http://www.securityfocus.com/bid/65539","https://www.openwall.com/lists/oss-security/2014/02/04/3","https://www.openwall.com/lists/oss-security/2014/02/04/4","http://seclists.org/oss-sec/2014/q1/245","http://seclists.org/oss-sec/2014/q1/335","http://www.debian.org/security/2014/dsa-2946"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-vcr5-xr9h-mvc5","url":"https://osv.dev/vulnerability/GHSA-vcr5-xr9h-mvc5"}],"summary":"python-gnupg vulnerable to shell injection"}