{"action":"Upgrade octoprint to 1.6.0 or later.","affected":[{"fixed":"1.6.0","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2021-32561"],"ecosystem":"PyPI","epss":0.01152,"exploited":false,"fixed_versions":["1.6.0"],"ghsa_id":"GHSA-vcx4-fpmp-mvv6","id":"tcs_01M5KFZZGKGT30PJC31GVP360E","modified_at":"2024-10-08T12:58:05.513021Z","published_at":"2022-05-24T19:02:06Z","references":["https://osv.dev/vulnerability/GHSA-vcx4-fpmp-mvv6","https://nvd.nist.gov/vuln/detail/CVE-2021-32561","https://github.com/OctoPrint/OctoPrint","https://github.com/OctoPrint/OctoPrint/releases/tag/1.6.0","https://github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2021-30.yaml","https://octoprint.org/blog/2021/04/27/new-release-1.6.0","https://www.brzozowski.io","https://www.brzozowski.io/web-applications/2021/05/11/the-insecure-story-of-octoprint.html"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-vcx4-fpmp-mvv6","url":"https://osv.dev/vulnerability/GHSA-vcx4-fpmp-mvv6"}],"summary":"OctoPrint API Error Messages vulnerable to XSS"}