{"action":"Upgrade pyanyapi to 0.6.1 or later.","affected":[{"fixed":"0.6.1","introduced":"0"}],"component":"pyanyapi","cve_ids":["CVE-2017-16616"],"ecosystem":"PyPI","epss":0.0362,"exploited":false,"fixed_versions":["0.6.1"],"ghsa_id":"GHSA-vg8g-jpm9-jh8r","id":"tcs_01M5KG04H0DWD128T1JET47MAJ","modified_at":"2024-10-21T21:01:58.950074Z","published_at":"2022-05-13T01:44:08Z","references":["https://osv.dev/vulnerability/GHSA-vg8g-jpm9-jh8r","https://nvd.nist.gov/vuln/detail/CVE-2017-16616","https://github.com/Stranger6667/pyanyapi/issues/41","https://github.com/Stranger6667/pyanyapi/commit/810db626c18ebc261d5f4299d0f0eac38d5eb3cf","https://github.com/Stranger6667/pyanyapi","https://github.com/Stranger6667/pyanyapi/releases/tag/0.6.1","https://github.com/advisories/GHSA-vg8g-jpm9-jh8r","https://github.com/pypa/advisory-database/tree/main/vulns/pyanyapi/PYSEC-2017-23.yaml","https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16616-yamlparser-in-pyanyapi","https://pypi.python.org/pypi/pyanyapi/0.6.1"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-vg8g-jpm9-jh8r","url":"https://osv.dev/vulnerability/GHSA-vg8g-jpm9-jh8r"}],"summary":"Unsafe pyyaml load usage in PyAnyAPI"}