{"action":"Upgrade tensorflow-gpu to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-35991"],"ecosystem":"PyPI","epss":0.00531,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-vm7x-4qhj-rrcq","id":"tcs_01M5KG0DBQTR9SFA9356PS83KA","modified_at":"2026-07-13T16:43:37.624150734Z","published_at":"2022-09-16T22:15:05Z","references":["https://osv.dev/vulnerability/GHSA-vm7x-4qhj-rrcq","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vm7x-4qhj-rrcq","https://nvd.nist.gov/vuln/detail/CVE-2022-35991","https://github.com/tensorflow/tensorflow/commit/bb03fdf4aae944ab2e4b35c7daa051068a8b7f61","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-vm7x-4qhj-rrcq#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-vm7x-4qhj-rrcq"}],"summary":"TensorFlow vulnerable to `CHECK` fail in `TensorListScatter` and `TensorListScatterV2`"}