{"action":"Upgrade xterm to 3.8.1 or later.","affected":[{"fixed":"3.8.1","introduced":"0"},{"fixed":"3.9.2","introduced":"3.9.0"},{"fixed":"3.10.1","introduced":"3.10.0"}],"component":"xterm","cve_ids":["CVE-2019-0542"],"ecosystem":"npm","epss":0.03166,"exploited":false,"fixed_versions":["3.8.1","3.9.2","3.10.1"],"ghsa_id":"GHSA-mc23-976p-j42x","id":"tcs_01M5KG0E22SPVTAPPHNC2Z5QSY","modified_at":"2023-11-08T04:00:32.652634Z","published_at":"2019-01-14T16:19:55Z","references":["https://osv.dev/vulnerability/GHSA-mc23-976p-j42x","https://nvd.nist.gov/vuln/detail/CVE-2019-0542","https://github.com/xtermjs/xterm.js/commit/3592c641cd0348e0b698e8a180aea2072c6bcd9a","https://access.redhat.com/errata/RHBA-2019:0959","https://access.redhat.com/errata/RHSA-2019:1422","https://access.redhat.com/errata/RHSA-2019:2551","https://access.redhat.com/errata/RHSA-2019:2552","https://github.com/advisories/GHSA-mc23-976p-j42x","https://github.com/xtermjs/xterm.js","https://github.com/xtermjs/xterm.js/releases/tag/3.8.1","http://www.securityfocus.com/bid/106434"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-mc23-976p-j42x","url":"https://osv.dev/vulnerability/GHSA-mc23-976p-j42x"}],"summary":"xterm vulnerable to remote code execution"}