{"action":"Upgrade next to 15.5.27 or later.","affected":[{"fixed":"16.3.8","introduced":"16.0.0"},{"fixed":"15.5.27","introduced":"15.0.0"}],"component":"next","cve_ids":["CVE-2026-94484"],"ecosystem":"npm","epss":0.00244,"exploited":false,"fixed_versions":["16.3.8","15.5.27"],"ghsa_id":"GHSA-mcj8-r9mp-w47p","id":"tcs_01M5KG0FMZ764MN11QD2VBHHJA","modified_at":"2026-10-07T20:45:04.800999218Z","published_at":"2026-10-07T20:31:13Z","references":["https://osv.dev/vulnerability/GHSA-mcj8-r9mp-w47p","https://github.com/vercel/next.js/security/advisories/GHSA-mcj8-r9mp-w47p","https://nvd.nist.gov/vuln/detail/CVE-2026-94484","https://github.com/vercel/next.js/commit/52c94abdd2ea5f416f5e8353ea8a2edd3fe311b8","https://github.com/vercel/next.js/commit/719e4c67d6e92df60246f95e1d96e2dd60789a52","https://github.com/vercel/next.js","https://github.com/vercel/next.js/releases/tag/v15.5.27","https://github.com/vercel/next.js/releases/tag/v16.3.8"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-mcj8-r9mp-w47p","url":"https://osv.dev/vulnerability/GHSA-mcj8-r9mp-w47p"}],"summary":"Next.js has cache poisoning in SSG/ISR rendering that leads to cross-user content substitution and persistent denial of service"}