{"action":"Upgrade github.com/kubernetes-csi/csi-proxy to 1.1.3 or later.","affected":[{"fixed":"1.1.3","introduced":"0"}],"component":"github.com/kubernetes-csi/csi-proxy","cve_ids":["CVE-2023-3893"],"ecosystem":"Go","epss":0.02475,"exploited":false,"fixed_versions":["1.1.3"],"ghsa_id":"GHSA-r6cc-7wj7-gfx2","id":"tcs_01M5KG0J3KW5R4PQEK0PDCPFAB","modified_at":"2026-03-03T04:54:20.134606Z","published_at":"2024-08-21T14:30:22Z","references":["https://osv.dev/vulnerability/GO-2023-2176","https://github.com/advisories/GHSA-r6cc-7wj7-gfx2","https://nvd.nist.gov/vuln/detail/CVE-2023-3893","https://github.com/kubernetes-csi/csi-proxy/commit/0e83a68159111e4ee510f5aa56d47ba97bda60c7","https://github.com/kubernetes-csi/csi-proxy/commit/2523e6674dedf3de27f84235efec28555da24664","https://github.com/kubernetes/kubernetes/issues/119594","https://groups.google.com/g/kubernetes-security-announce/c/lWksE2BoCyQ","https://security.netapp.com/advisory/ntap-20231221-0004"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2023-2176","url":"https://osv.dev/vulnerability/GO-2023-2176"}],"summary":"Kubernetes csi-proxy vulnerable to privilege escalation due to improper input validation in github.com/kubernetes-csi/csi-proxy"}