{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29581"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-vq2r-5xvm-3hc3","id":"tcs_01M5KG0JYJ4SC69V5RKWSDCN5Z","modified_at":"2026-07-08T06:29:31.828776763Z","published_at":"2021-05-21T14:26:30Z","references":["https://osv.dev/vulnerability/GHSA-vq2r-5xvm-3hc3","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq2r-5xvm-3hc3","https://nvd.nist.gov/vuln/detail/CVE-2021-29581","https://github.com/tensorflow/tensorflow/commit/b1b323042264740c398140da32e93fb9c2c9f33e","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-509.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-707.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-218.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-vq2r-5xvm-3hc3#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-vq2r-5xvm-3hc3"}],"summary":"Segfault in `CTCBeamSearchDecoder`"}