{"action":"Upgrade fastify to 4.29.1 or later.","affected":[{"fixed":"5.3.2","introduced":"5.0.0"},{"fixed":"4.29.1","introduced":"4.29.0"}],"component":"fastify","cve_ids":["CVE-2025-32442","CVE-2026-33806"],"ecosystem":"npm","epss":0.00729,"exploited":false,"fixed_versions":["5.3.2","4.29.1"],"ghsa_id":"GHSA-mg2h-6x62-wpwc","id":"tcs_01M5KG0KWBVDMSM99AYPS7M93B","modified_at":"2026-07-08T08:11:12.813453393Z","published_at":"2025-04-18T15:02:41Z","references":["https://osv.dev/vulnerability/GHSA-mg2h-6x62-wpwc","https://github.com/fastify/fastify/security/advisories/GHSA-mg2h-6x62-wpwc","https://nvd.nist.gov/vuln/detail/CVE-2025-32442","https://github.com/fastify/fastify/commit/436da4c06dfbbb8c24adee3a64de0c51e4f47418","https://github.com/fastify/fastify/commit/f3d2bcb3963cd570a582e5d39aab01a9ae692fe4","https://hackerone.com/reports/3087928","https://github.com/fastify/fastify"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-mg2h-6x62-wpwc","url":"https://osv.dev/vulnerability/GHSA-mg2h-6x62-wpwc"}],"summary":"Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass"}