{"action":"Upgrade gatsby-plugin-mdx to 2.14.1 or later.","affected":[{"fixed":"2.14.1","introduced":"0"},{"fixed":"3.15.2","introduced":"3.0.0"}],"component":"gatsby-plugin-mdx","cve_ids":["CVE-2022-25863"],"ecosystem":"npm","epss":0.01992,"exploited":false,"fixed_versions":["2.14.1","3.15.2"],"ghsa_id":"GHSA-mj46-r4gr-5x83","id":"tcs_01M5KG0W3WMY3A1GEMT0DN9JV9","modified_at":"2026-07-08T06:50:01.480369243Z","published_at":"2022-06-03T22:32:06Z","references":["https://osv.dev/vulnerability/GHSA-mj46-r4gr-5x83","https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-mj46-r4gr-5x83","https://nvd.nist.gov/vuln/detail/CVE-2022-25863","https://github.com/gatsbyjs/gatsby/pull/35830","https://github.com/gatsbyjs/gatsby/pull/35830/commits/f214eb0694c61e348b2751cecd1aace2046bc46e","https://drive.google.com/file/d/1EoCzbwTWOM8-fjvwMbH3bqcZ2iKksxTW/view?usp=sharing","https://github.com/gatsbyjs/gatsby","https://snyk.io/vuln/SNYK-JS-GATSBYPLUGINMDX-2405699"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-mj46-r4gr-5x83","url":"https://osv.dev/vulnerability/GHSA-mj46-r4gr-5x83"}],"summary":"Unsanitized JavaScript code injection possible in gatsby-plugin-mdx"}