{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29613"],"ecosystem":"PyPI","epss":0.0024,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-vvg4-vgrv-xfr7","id":"tcs_01M5KG0XCWXB4KJD9YFCFJHECH","modified_at":"2026-09-10T03:49:06.057481500Z","published_at":"2021-05-21T14:28:39Z","references":["https://osv.dev/vulnerability/GHSA-vvg4-vgrv-xfr7","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vvg4-vgrv-xfr7","https://nvd.nist.gov/vuln/detail/CVE-2021-29613","https://github.com/tensorflow/tensorflow/commit/14607c0707040d775e06b6817325640cb4b5864c","https://github.com/tensorflow/tensorflow/commit/4504a081af71514bb1828048363e6540f797005b","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-541.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-739.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-250.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-vvg4-vgrv-xfr7#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-vvg4-vgrv-xfr7"}],"summary":"Incomplete validation in `tf.raw_ops.CTCLoss`"}