{"action":"Upgrade proxy to 2.1.1 or later.","affected":[{"fixed":"2.1.1","introduced":"2.0.0"}],"component":"proxy","cve_ids":["CVE-2023-2968"],"ecosystem":"npm","epss":0.01478,"exploited":false,"fixed_versions":["2.1.1"],"ghsa_id":"GHSA-mj6p-3pc9-wf5m","id":"tcs_01M5KG0XN7ZAYZPDV7WXSMS8R2","modified_at":"2026-06-11T14:30:10.425806849Z","published_at":"2023-05-30T18:30:23Z","references":["https://osv.dev/vulnerability/GHSA-mj6p-3pc9-wf5m","https://nvd.nist.gov/vuln/detail/CVE-2023-2968","https://github.com/TooTallNate/proxy-agents/pull/178","https://github.com/TooTallNate/proxy-agents/commit/25e0c931390eb8f41c5ceaca72820de9198ece39","https://github.com/TooTallNate/proxy-agents","https://research.jfrog.com/vulnerabilities/undefined-variable-usage-in-proxy-leads-to-remote-denial-of-service-xray-520917"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-mj6p-3pc9-wf5m","url":"https://osv.dev/vulnerability/GHSA-mj6p-3pc9-wf5m"}],"summary":"proxy denial of service vulnerability"}