{"action":"Upgrade tensorflow to 2.4.4 or later.","affected":[{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"}],"component":"tensorflow","cve_ids":["CVE-2021-41214"],"ecosystem":"PyPI","epss":0.00217,"exploited":false,"fixed_versions":["2.6.1","2.5.2","2.4.4"],"ghsa_id":"GHSA-vwhq-49r4-gj9v","id":"tcs_01M5KG0ZKWYBME4JZBXT199M5V","modified_at":"2026-07-08T06:28:17.058956556Z","published_at":"2021-11-10T18:58:16Z","references":["https://osv.dev/vulnerability/GHSA-vwhq-49r4-gj9v","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vwhq-49r4-gj9v","https://nvd.nist.gov/vuln/detail/CVE-2021-41214","https://github.com/tensorflow/tensorflow/commit/fa6b7782fbb14aa08d767bc799c531f5e1fb3bb8","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-623.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-821.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-406.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-vwhq-49r4-gj9v","url":"https://osv.dev/vulnerability/GHSA-vwhq-49r4-gj9v"}],"summary":"Reference binding to `nullptr` in `tf.ragged.cross`"}