{"action":"Upgrade wagtail to 6.0.3 or later.","affected":[{"fixed":"6.0.3","introduced":"6.0.0"}],"component":"wagtail","cve_ids":["CVE-2024-32882"],"ecosystem":"PyPI","epss":0.00483,"exploited":false,"fixed_versions":["6.0.3"],"ghsa_id":"GHSA-w2v8-php4-p8hc","id":"tcs_01M5KG18FNP2F92A4EZBP41YCM","modified_at":"2026-09-10T03:50:14.432021144Z","published_at":"2024-05-01T16:35:13Z","references":["https://osv.dev/vulnerability/GHSA-w2v8-php4-p8hc","https://github.com/wagtail/wagtail/security/advisories/GHSA-w2v8-php4-p8hc","https://nvd.nist.gov/vuln/detail/CVE-2024-32882","https://github.com/wagtail/wagtail/commit/ab2a5d82b4ee3c909d2456704388ccf90e367c9b","https://github.com/wagtail/wagtail/commit/fa0d4829f9c81eefb37cc058e2fa1b6a918741da","https://docs.wagtail.org/en/stable/extending/generic_views.html#modelviewset","https://docs.wagtail.org/en/stable/reference/contrib/settings.html","https://docs.wagtail.org/en/stable/reference/pages/panels.html#wagtail.admin.panels.FieldPanel.permission","https://github.com/wagtail/wagtail","https://github.com/wagtail/wagtail/releases/tag/v6.0.3"],"severity":{"label":"low","score":2.7},"sources":[{"source":"osv","source_id":"GHSA-w2v8-php4-p8hc","url":"https://osv.dev/vulnerability/GHSA-w2v8-php4-p8hc"}],"summary":"Wagtail has permission check bypass when editing a model with per-field restrictions through `wagtail.contrib.settings` or `ModelViewSet`"}