{"action":"Upgrade guardrails-ai to 0.5.10 or later.","affected":[{"fixed":"0.5.10","introduced":"0.2.9"}],"component":"guardrails-ai","cve_ids":["CVE-2024-45858"],"ecosystem":"PyPI","epss":0.00378,"exploited":false,"fixed_versions":["0.5.10"],"ghsa_id":"GHSA-w392-75q8-vr67","id":"tcs_01M5KG19ETEP5YHKPRV5YEM45A","modified_at":"2026-07-07T17:56:13.825660483Z","published_at":"2024-09-18T15:30:52Z","references":["https://osv.dev/vulnerability/GHSA-w392-75q8-vr67","https://nvd.nist.gov/vuln/detail/CVE-2024-45858","https://github.com/guardrails-ai/guardrails/commit/ab12701e8c3ef41273ff9b3912f2e4e28ae8306f","https://github.com/guardrails-ai/guardrails","https://hiddenlayer.com/sai-security-advisory/2024-09-guardrails"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-w392-75q8-vr67","url":"https://osv.dev/vulnerability/GHSA-w392-75q8-vr67"}],"summary":"Guardrails has an arbitrary code execution vulnerability"}