{"action":"Upgrade tensorflow-cpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-37666"],"ecosystem":"PyPI","epss":0.00173,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-w4xf-2pqw-5mq7","id":"tcs_01M5KG1DPKZEAM2D5GEVA38NJ2","modified_at":"2026-09-10T03:49:08.985245762Z","published_at":"2021-08-25T14:42:13Z","references":["https://osv.dev/vulnerability/GHSA-w4xf-2pqw-5mq7","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-w4xf-2pqw-5mq7","https://nvd.nist.gov/vuln/detail/CVE-2021-37666","https://github.com/tensorflow/tensorflow/commit/be7a4de6adfbd303ce08be4332554dff70362612","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-579.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-777.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-288.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-w4xf-2pqw-5mq7#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-w4xf-2pqw-5mq7"}],"summary":"Reference binding to nullptr in `RaggedTensorToVariant`"}