{"action":"Upgrade ansible to 2.1.6.0 or later.","affected":[{"fixed":"2.3.1.0","introduced":"2.3.0.0"},{"fixed":"2.1.6.0","introduced":"0"},{"fixed":"2.2.3.0","introduced":"2.2.0.0"}],"component":"ansible","cve_ids":["CVE-2017-7481"],"ecosystem":"PyPI","epss":0.04782,"exploited":false,"fixed_versions":["2.3.1.0","2.1.6.0","2.2.3.0"],"ghsa_id":"GHSA-w578-j992-554x","id":"tcs_01M5KG1E05QTZV1CDKDDNW2EKG","modified_at":"2025-05-29T22:55:27.692255Z","published_at":"2018-09-06T03:28:50Z","references":["https://osv.dev/vulnerability/GHSA-w578-j992-554x","https://nvd.nist.gov/vuln/detail/CVE-2017-7481","https://github.com/ansible/ansible/commit/fd30f5328986f9e1da434474481f32bf918a600c","https://github.com/ansible/ansible/commit/f0e348f5eeb70c1fb3127d90891da43b5c0a9d29","https://github.com/ansible/ansible/commit/ed56f51f185a1ffd7ea57130d260098686fcc7c2","https://github.com/ansible/ansible/commit/a1886911fcf4b691130cfc70dfc5daa5e07c46a3","https://web.archive.org/web/20170801122609/http://www.securityfocus.com/bid/98492","https://usn.ubuntu.com/4072-1","https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-41.yaml","https://github.com/ansible/ansible","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7481","https://access.redhat.com/errata/RHSA-2017:2524","https://access.redhat.com/errata/RHSA-2017:1599","https://access.redhat.com/errata/RHSA-2017:1499","https://access.redhat.com/errata/RHSA-2017:1476","https://access.redhat.com/errata/RHSA-2017:1334","https://access.redhat.com/errata/RHSA-2017:1244"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-w578-j992-554x","url":"https://osv.dev/vulnerability/GHSA-w578-j992-554x"}],"summary":"Ansible fails to properly mark lookup-plugin results as unsafe"}