{"action":"Upgrade powerline-gitstatus to 1.3.2 or later.","affected":[{"fixed":"1.3.2","introduced":"0"}],"component":"powerline-gitstatus","cve_ids":["CVE-2022-42906"],"ecosystem":"PyPI","epss":0.00477,"exploited":false,"fixed_versions":["1.3.2"],"ghsa_id":"GHSA-w67g-6gjv-c599","id":"tcs_01M5KG1HF9Z4RZ04BT58NX4MDY","modified_at":"2026-07-07T11:56:20.123796374Z","published_at":"2022-10-13T12:00:26Z","references":["https://osv.dev/vulnerability/GHSA-w67g-6gjv-c599","https://nvd.nist.gov/vuln/detail/CVE-2022-42906","https://github.com/jaspernbrouwer/powerline-gitstatus/issues/45","https://github.com/jaspernbrouwer/powerline-gitstatus/commit/fe8e963b3489e4cceaa2c1f26f2bcc2ef405364c","https://github.com/jaspernbrouwer/powerline-gitstatus","https://github.com/jaspernbrouwer/powerline-gitstatus/releases/tag/v1.3.2","https://lists.debian.org/debian-lts-announce/2023/01/msg00017.html"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-w67g-6gjv-c599","url":"https://osv.dev/vulnerability/GHSA-w67g-6gjv-c599"}],"summary":"Powerline Gitstatus vulnerable to arbitrary code execution"}