{"action":"Upgrade tensorflow-gpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-37667"],"ecosystem":"PyPI","epss":0.00173,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-w74j-v8xh-3w5h","id":"tcs_01M5KG1MT4Q0M228AC32T8MHKR","modified_at":"2026-07-08T06:00:26.605606799Z","published_at":"2021-08-25T14:42:09Z","references":["https://osv.dev/vulnerability/GHSA-w74j-v8xh-3w5h","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-w74j-v8xh-3w5h","https://nvd.nist.gov/vuln/detail/CVE-2021-37667","https://github.com/tensorflow/tensorflow/commit/2e0ee46f1a47675152d3d865797a18358881d7a6","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-580.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-778.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-289.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-w74j-v8xh-3w5h#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-w74j-v8xh-3w5h"}],"summary":"Reference binding to nullptr in unicode encoding"}