{"action":"Upgrade ansible-core to 2.16.19rc1 or later.","affected":[{"fixed":"2.16.19rc1","introduced":"0"},{"fixed":"2.18.18rc1","introduced":"2.17.0b1"},{"fixed":"2.19.11rc1","introduced":"2.19.0b1"},{"fixed":"2.20.7rc1","introduced":"2.20.0b1"},{"fixed":"2.21.1rc1","introduced":"2.21.0b1"}],"component":"ansible-core","cve_ids":["CVE-2026-11332"],"ecosystem":"PyPI","epss":0.00222,"exploited":false,"fixed_versions":["2.16.19rc1","2.18.18rc1","2.19.11rc1","2.20.7rc1","2.21.1rc1"],"ghsa_id":"GHSA-w8p5-mx5w-cpqj","id":"tcs_01M5KG1TKN2W2TA3AM0XET5YQP","modified_at":"2026-07-23T15:11:38.566563365Z","published_at":"2026-06-05T09:33:46Z","references":["https://osv.dev/vulnerability/GHSA-w8p5-mx5w-cpqj","https://nvd.nist.gov/vuln/detail/CVE-2026-11332","https://github.com/ansible/ansible/pull/87070","https://github.com/ansible/ansible/commit/edee59aa15abcc74d920bb3e9c3835ab8db05a2f","https://access.redhat.com/security/cve/CVE-2026-11332","https://bugzilla.redhat.com/show_bug.cgi?id=2485379","https://github.com/ansible/ansible","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-11332.json"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-w8p5-mx5w-cpqj","url":"https://osv.dev/vulnerability/GHSA-w8p5-mx5w-cpqj"}],"summary":"ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution"}