{"action":"Upgrade matrix-synapse to 1.28.0 or later.","affected":[{"fixed":"1.28.0","introduced":"0"}],"component":"matrix-synapse","cve_ids":["CVE-2021-21394"],"ecosystem":"PyPI","epss":0.01538,"exploited":false,"fixed_versions":["1.28.0"],"ghsa_id":"GHSA-w9fg-xffh-p362","id":"tcs_01M5KG1WADWRM9N3F1YFMXGSH2","modified_at":"2026-07-08T06:30:03.309970611Z","published_at":"2021-04-13T15:12:51Z","references":["https://osv.dev/vulnerability/GHSA-w9fg-xffh-p362","https://github.com/matrix-org/synapse/security/advisories/GHSA-w9fg-xffh-p362","https://nvd.nist.gov/vuln/detail/CVE-2021-21394","https://github.com/matrix-org/synapse/pull/9321","https://github.com/matrix-org/synapse/pull/9393","https://github.com/matrix-org/synapse","https://github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2021-27.yaml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TNNAJOZNMVMXM6AS7RFFKB4QLUJ4IFEY","https://pypi.org/project/matrix-synapse"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-w9fg-xffh-p362","url":"https://osv.dev/vulnerability/GHSA-w9fg-xffh-p362"}],"summary":"Denial of service (via resource exhaustion) due to improper input validation on third-party identifier endpoints"}