{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29520"],"ecosystem":"PyPI","epss":0.00224,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-wcv5-qrj6-9pfm","id":"tcs_01M5KG20PKWVC4FKSQR5VN5GEA","modified_at":"2026-07-08T06:28:26.491408320Z","published_at":"2021-05-21T14:21:12Z","references":["https://osv.dev/vulnerability/GHSA-wcv5-qrj6-9pfm","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wcv5-qrj6-9pfm","https://nvd.nist.gov/vuln/detail/CVE-2021-29520","https://github.com/tensorflow/tensorflow/commit/8f37b52e1320d8d72a9529b2468277791a261197","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-448.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-646.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-157.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-wcv5-qrj6-9pfm#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-wcv5-qrj6-9pfm"}],"summary":"Heap buffer overflow in `Conv3DBackprop*`"}