{"action":"Upgrade @apollo/gateway to 2.10.1 or later.","affected":[{"fixed":"2.10.1","introduced":"0"}],"component":"@apollo/gateway","cve_ids":["CVE-2025-32031"],"ecosystem":"npm","epss":0.00591,"exploited":false,"fixed_versions":["2.10.1"],"ghsa_id":"GHSA-p2q6-pwh5-m6jr","id":"tcs_01M5KG29FZ1KR3QQN4V5YYG1D7","modified_at":"2025-04-08T17:50:52Z","published_at":"2025-04-07T19:03:16Z","references":["https://osv.dev/vulnerability/GHSA-p2q6-pwh5-m6jr","https://github.com/apollographql/federation/security/advisories/GHSA-p2q6-pwh5-m6jr","https://nvd.nist.gov/vuln/detail/CVE-2025-32031","https://github.com/apollographql/federation/pull/3236","https://github.com/apollographql/federation","https://github.com/apollographql/federation/releases/tag/%40apollo%2Fgateway%402.10.1"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-p2q6-pwh5-m6jr","url":"https://osv.dev/vulnerability/GHSA-p2q6-pwh5-m6jr"}],"summary":"Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass"}