{"action":"Upgrade sagemaker to 2.218.0 or later.","affected":[{"fixed":"2.218.0","introduced":"0"}],"component":"sagemaker","cve_ids":["CVE-2024-34072"],"ecosystem":"PyPI","epss":0.00411,"exploited":false,"fixed_versions":["2.218.0"],"ghsa_id":"GHSA-wjvx-jhpj-r54r","id":"tcs_01M5KG2CZ37BTQG1DC10XNM4VZ","modified_at":"2026-09-10T03:50:14.667578197Z","published_at":"2024-05-03T20:25:33Z","references":["https://osv.dev/vulnerability/GHSA-wjvx-jhpj-r54r","https://github.com/aws/sagemaker-python-sdk/security/advisories/GHSA-wjvx-jhpj-r54r","https://nvd.nist.gov/vuln/detail/CVE-2024-34072","https://github.com/aws/sagemaker-python-sdk/pull/4557","https://github.com/aws/sagemaker-python-sdk/commit/72e0c9712aec6fbb82fb40fda091dfc2a42c70a0","https://github.com/aws/sagemaker-python-sdk"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-wjvx-jhpj-r54r","url":"https://osv.dev/vulnerability/GHSA-wjvx-jhpj-r54r"}],"summary":"sagemaker-python-sdk vulnerable to Deserialization of Untrusted Data"}