{"action":"Upgrade tensorflow to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow","cve_ids":["CVE-2022-23576"],"ecosystem":"PyPI","epss":0.00783,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-wm93-f238-7v37","id":"tcs_01M5KG2EHT6FP3R8EW4WKZPF8Q","modified_at":"2026-07-13T16:43:39.673455519Z","published_at":"2022-02-10T00:32:44Z","references":["https://osv.dev/vulnerability/GHSA-wm93-f238-7v37","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wm93-f238-7v37","https://nvd.nist.gov/vuln/detail/CVE-2022-23576","https://github.com/tensorflow/tensorflow/commit/b9bd6cfd1c50e6807846af9a86f9b83cafc9c8ae","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-85.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-140.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/costs/op_level_cost_estimator.cc#L1598-L1617"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-wm93-f238-7v37","url":"https://osv.dev/vulnerability/GHSA-wm93-f238-7v37"}],"summary":"Integer overflow in Tensorflow"}