{"action":"Upgrade nodebb to 1.19.8 or later.","affected":[{"fixed":"1.19.8","introduced":"0"},{"fixed":"2.0.1","introduced":"2.0.0"}],"component":"nodebb","cve_ids":["CVE-2022-36045"],"ecosystem":"npm","epss":0.01349,"exploited":false,"fixed_versions":["1.19.8","2.0.1"],"ghsa_id":"GHSA-p4cc-w597-6cpm","id":"tcs_01M5KG2GHSCCW5RGP25NXAW5C3","modified_at":"2023-11-08T04:09:58.724209Z","published_at":"2022-08-30T20:38:10Z","references":["https://osv.dev/vulnerability/GHSA-p4cc-w597-6cpm","https://github.com/NodeBB/NodeBB/security/advisories/GHSA-p4cc-w597-6cpm","https://nvd.nist.gov/vuln/detail/CVE-2022-36045","https://github.com/NodeBB/NodeBB/commit/81e3c1ba488d03371a5ce8d0ebb5c5803026e0f9","https://github.com/NodeBB/NodeBB/commit/e802fab87f94a13f397f04cfe6068f2f7ddf7888","https://github.com/NodeBB/NodeBB"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-p4cc-w597-6cpm","url":"https://osv.dev/vulnerability/GHSA-p4cc-w597-6cpm"}],"summary":"Cryptographically weak PRNG in `utils.generateUUID`"}