{"action":"Upgrade uap-core to 0.11.0 or later.","affected":[{"fixed":"0.11.0","introduced":"0"}],"component":"uap-core","cve_ids":["CVE-2021-21317"],"ecosystem":"npm","epss":0.02517,"exploited":false,"fixed_versions":["0.11.0"],"ghsa_id":"GHSA-p4pj-mg4r-x6v4","id":"tcs_01M5KG2HY4317B6Q7Q50PN3X7K","modified_at":"2026-07-08T06:27:33.229785880Z","published_at":"2021-02-02T15:46:38Z","references":["https://osv.dev/vulnerability/GHSA-p4pj-mg4r-x6v4","https://github.com/ua-parser/uap-core/security/advisories/GHSA-p4pj-mg4r-x6v4","https://nvd.nist.gov/vuln/detail/CVE-2021-21317","https://github.com/ua-parser/uap-core/commit/dc9925d458214cfe87b93e35346980612f6ae96c","https://github.com/ua-parser/uap-core","https://www.npmjs.com/package/uap-core"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-p4pj-mg4r-x6v4","url":"https://osv.dev/vulnerability/GHSA-p4pj-mg4r-x6v4"}],"summary":"Denial of Service in uap-core"}