{"action":"Upgrade tensorflow-cpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-37648"],"ecosystem":"PyPI","epss":0.00186,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-wp77-4gmm-7cq8","id":"tcs_01M5KG2JGZAK5TVMSDTM6EX3HP","modified_at":"2026-07-08T06:29:24.276113092Z","published_at":"2021-08-25T14:43:29Z","references":["https://osv.dev/vulnerability/GHSA-wp77-4gmm-7cq8","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wp77-4gmm-7cq8","https://nvd.nist.gov/vuln/detail/CVE-2021-37648","https://github.com/tensorflow/tensorflow/commit/9728c60e136912a12d99ca56e106b7cce7af5986","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-561.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-759.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-270.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-wp77-4gmm-7cq8#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-wp77-4gmm-7cq8"}],"summary":"Incorrect validation of `SaveV2` inputs"}